yarn error file-loader@2.0.0: The engine "node" is incompatible with this module. Expected version

问题:rax项目执行yarn 时报错

[1/4] ?  Resolving packages...
[2/4] ?  Fetching packages...
error file-loader@2.0.0: The engine "node" is incompatible with this module. Expected version ">= 6.9.0 < 7.0.0 || >= 8.9.0". Got "8.3.0"
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
`yarn install` failed

解决方法:加 --ignore-engines
yarn --ignore-engines

➜  hello-world yarn --ignore-engines
yarn install v1.12.1
warning package.json: No license field
info No lockfile found.
warning hello-world@0.0.0: No license field
[1/4] ?  Resolving packages...
[2/4] ?  Fetching packages...
[3/4] ?  Linking dependencies...
warning "rax-scripts > rax-hot-loader@0.6.5" has incorrect peer dependency "rax@^0.6.5".
[4/4] ?  Building fresh packages...
success Saved lockfile.
✨  Done in 29.01s.
已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页